libssh2: add mbedtls backend
authorBaruch Siach <baruch@tkos.co.il>
Mon, 10 Jul 2017 17:35:54 +0000 (20:35 +0300)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 11 Jul 2017 19:34:56 +0000 (21:34 +0200)
libssh2 support mbedtls as crypto back-end library since version 1.8.0.

Default to mbedtls since it's smaller than either libgcrypt or openssl.

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libssh2/Config.in
package/libssh2/libssh2.mk

index 2944624e0a7564ab2e7a035dda3f75f19de0f38c..9b60823e7a8a7a1100ea453e698fdceb572da2ac 100644 (file)
@@ -1,6 +1,6 @@
 config BR2_PACKAGE_LIBSSH2
        bool "libssh2"
-       select BR2_PACKAGE_OPENSSL if !BR2_PACKAGE_LIBGCRYPT
+       select BR2_PACKAGE_OPENSSL if !(BR2_PACKAGE_MBEDTLS || BR2_PACKAGE_LIBGCRYPT)
        help
          libssh2 is a client-side C library implementing the SSH2
          protocol as defined by Internet Drafts: SECSH-TRANS(22),
index c658282349be95dd617fe7c344681d2dcc4b6b1d..338f5b458f11e49da8b75187f6cf2c9e8a2ca986 100644 (file)
@@ -11,12 +11,16 @@ LIBSSH2_LICENSE_FILES = COPYING
 LIBSSH2_INSTALL_STAGING = YES
 LIBSSH2_CONF_OPTS = --disable-examples-build
 
-# Dependency is either on libgcrypt or openssl, guaranteed in Config.in.
-# Favour libgcrypt.
-ifeq ($(BR2_PACKAGE_LIBGCRYPT),y)
+# Dependency is one of mbedtls, libgcrypt or openssl, guaranteed in
+# Config.in. Favour mbedtls.
+ifeq ($(BR2_PACKAGE_MBEDTLS),y)
+LIBSSH2_DEPENDENCIES += mbedtls
+LIBSSH2_CONF_OPTS += --with-mbedtls=$(STAGING_DIR)/usr \
+       --without-openssl --without-libgcrypt
+else ifeq ($(BR2_PACKAGE_LIBGCRYPT),y)
 LIBSSH2_DEPENDENCIES += libgcrypt
 LIBSSH2_CONF_OPTS += --with-libgcrypt=$(STAGING_DIR)/usr \
-       --without-openssl
+       --without-openssl --without-mbedtls
 # configure.ac forgets to link to dependent libraries of gcrypt breaking static
 # linking
 LIBSSH2_CONF_ENV += LIBS="`$(STAGING_DIR)/usr/bin/libgcrypt-config --libs`"
@@ -24,7 +28,7 @@ else
 LIBSSH2_DEPENDENCIES += openssl
 LIBSSH2_CONF_OPTS += --with-openssl \
        --with-libssl-prefix=$(STAGING_DIR)/usr \
-       --without-libgcrypt
+       --without-libgcrypt --without-mbedtls
 endif
 
 # Add zlib support if enabled