read-edid: make available for !x86
authorPeter Korsgaard <peter@korsgaard.com>
Wed, 14 Jan 2015 15:30:58 +0000 (16:30 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 14 Jan 2015 15:33:40 +0000 (16:33 +0100)
It is only the get-edid tool that is x86 specific, parse-edid builds and
works fine on other architectures so make it available everywhere.

Also drop the custom install step as 'make install' does the right thing.
This does cause us to install into /usr/sbin instead of /sbin, but as that
is what upstream wants we can consider that a bugfix.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/read-edid/Config.in
package/read-edid/read-edid.mk

index bdcb7a7d2e4e4cb7c76faaabe796c9b136fe744a..f1ad1c4979d7f82abd2441b8e8c1d8496f476767 100644 (file)
@@ -1,6 +1,5 @@
 config BR2_PACKAGE_READ_EDID
        bool "read-edid"
-       depends on BR2_i386
        help
          Read-edid is a pair of tools for reading the EDID from a
          monitor.  It should work with most monitors made since 1996
@@ -11,4 +10,6 @@ config BR2_PACKAGE_READ_EDID
          which turns the raw binary information into an
          XF86Config-compatible monitor section.
 
+         Notice that the get-edid tool is only available on x86.
+
          http://polypux.org/projects/read-edid/
index 54064d38dbfb0fe29ee3d8d90b47268b0f3668d9..f047e79b8dd0db6acf8811f2ffb7fb7a048f1671 100644 (file)
@@ -13,9 +13,4 @@ define READ_EDID_BUILD_CMDS
        $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)
 endef
 
-define READ_EDID_INSTALL_TARGET_CMDS
-       $(INSTALL) -D -m 0755 $(@D)/get-edid $(TARGET_DIR)/sbin/get-edid
-       $(INSTALL) -D -m 0755 $(@D)/parse-edid $(TARGET_DIR)/sbin/parse-edid
-endef
-
 $(eval $(autotools-package))