package/gdb: also disable gprof
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 28 Sep 2020 20:11:27 +0000 (22:11 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Wed, 30 Sep 2020 20:47:10 +0000 (22:47 +0200)
When gdb is built from sources fetched from Git, it contains both the
gdb and the binutils code base. In order to really build only gdb, we
disable a number of binutils components in the
GDB_DISABLE_BINUTILS_CONF_OPTS variable: --disable-binutils,
--disable-ld, --disable-gas, etc. However, gprof was still being
built, so disable it as well.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/gdb/gdb.mk

index 2e5588bfbc7a8be3acc638d7b99ac65a172a6b1a..f31b168bf1eab801154a92b77a3dcc5b8fff5c75 100644 (file)
@@ -81,7 +81,8 @@ GDB_DISABLE_BINUTILS_CONF_OPTS = \
        --disable-binutils \
        --disable-install-libbfd \
        --disable-ld \
-       --disable-gas
+       --disable-gas \
+       --disable-gprof
 
 GDB_CONF_ENV = \
        ac_cv_type_uintptr_t=yes \