libcurl: security bump to version 7.36.0
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 31 Mar 2014 22:34:58 +0000 (19:34 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 1 Apr 2014 12:45:20 +0000 (14:45 +0200)
Fixes CVE-2014-0005, CVE-2014-0319, CVE-2014-1263 and CVE-2014-2522.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libcurl/libcurl-01-disable-manual.patch [new file with mode: 0644]
package/libcurl/libcurl.mk

diff --git a/package/libcurl/libcurl-01-disable-manual.patch b/package/libcurl/libcurl-01-disable-manual.patch
new file mode 100644 (file)
index 0000000..4872169
--- /dev/null
@@ -0,0 +1,31 @@
+Apply fix from 38d582ff541353d738858299d4a2b78bafac03ed to unbreak
+building with --disable-manual.
+We don't use the literal patch since that means re-generating files
+from the tarball that are usually shipped.
+
+Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
+
+diff -Nura curl-7.36.0.orig/src/tool_hugehelp.c curl-7.36.0/src/tool_hugehelp.c
+--- curl-7.36.0.orig/src/tool_hugehelp.c       2014-03-31 19:28:23.018515093 -0300
++++ curl-7.36.0/src/tool_hugehelp.c    2014-03-31 19:28:09.994076200 -0300
+@@ -4165,6 +4165,10 @@
+ "  these mailing lists instead of mailing any individual.\n"
+ , stdout) ;
+ }
++#else /* !USE_MANUAL */
++/* built-in manual is disabled, blank function */
++#include "tool_hugehelp.h"
++void hugehelp(void) {}
+ #endif /* USE_MANUAL */
+ #else
+ /*
+@@ -8192,5 +8196,9 @@
+   }
+   inflateEnd(&z);
+ }
++#else
++/* built-in manual is disabled, blank function */
++#include "tool_hugehelp.h"
++void hugehelp(void) {}
+ #endif /* USE_MANUAL */
+ #endif /* HAVE_LIBZ */
index 458dfb620efc8a40d84b0e90b4131ac552c5fe3f..ab558fb532bad3efeab52a6b28b2f0fd71fdcd04 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-LIBCURL_VERSION = 7.35.0
+LIBCURL_VERSION = 7.36.0
 LIBCURL_SOURCE = curl-$(LIBCURL_VERSION).tar.bz2
 LIBCURL_SITE = http://curl.haxx.se/download
 LIBCURL_DEPENDENCIES = host-pkgconf \