host-libxml2: enable debug for mesa3d
authorArnout Vandecappelle <arnout@mind.be>
Tue, 11 Dec 2012 01:10:07 +0000 (01:10 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 16 Dec 2012 00:18:57 +0000 (01:18 +0100)
The API generation script in mesa3d requires libxml2 to be built with
debug, because it uses the lsCountNode function which is only available
in debug mode.

Note that this is the second "temporary" hack to make mesa3d work.
See http://lists.busybox.net/pipermail/buildroot/2012-November/061936.html
for possible more fundamental solutions.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/libxml2/libxml2.mk

index fde3735b8de7a8675dd282215d1f321bfd40f558..0c84652dd740584b778c39a9d38be12ab56fe4c7 100644 (file)
@@ -26,7 +26,12 @@ LIBXML2_POST_INSTALL_STAGING_HOOKS += LIBXML2_STAGING_LIBXML2_CONFIG_FIXUP
 
 HOST_LIBXML2_DEPENDENCIES = host-pkgconf
 
+# mesa3d uses functions that are only available with debug
+ifeq ($(BR2_PACKAGE_MESA3D),y)
+HOST_LIBXML2_CONF_OPT = --with-debug
+else
 HOST_LIBXML2_CONF_OPT = --without-debug
+endif
 
 ifeq ($(BR2_PACKAGE_HOST_LIBXML2_PYTHON),y)
 HOST_LIBXML2_DEPENDENCIES += host-python