perl-appconfig: new package
authorChristopher McCrory <chrismcc@gmail.com>
Fri, 10 Aug 2018 16:14:45 +0000 (09:14 -0700)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 12 Aug 2018 21:10:21 +0000 (23:10 +0200)
Signed-off-by: Christopher McCrory <chrismcc@gmail.com>
Acked-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/perl-appconfig/Config.in [new file with mode: 0644]
package/perl-appconfig/perl-appconfig.hash [new file with mode: 0644]
package/perl-appconfig/perl-appconfig.mk [new file with mode: 0644]

index e0e37a031a32a9501f75d61415639c5dfe16ee58..1b0af622c47615b5241037161f2fcea96236c7a9 100644 (file)
@@ -480,6 +480,9 @@ F:  package/python-rtslib-fb/
 F:     package/python-urwid/
 F:     package/targetcli-fb/
 
+N:     Christopher McCrory <chrismcc@gmail.com>
+F:     package/perl-appconfig/
+
 N:     Clayton Shotwell <clayton.shotwell@rockwellcollins.com>
 F:     package/audit/
 F:     package/checkpolicy/
index bc6df3a3b013dba6cd77c298091fdec9762cdc38..d3b7c5b0d7b4531569358d23a8efc8deed250c43 100644 (file)
@@ -665,6 +665,7 @@ endif
        source "package/perl/Config.in"
 if BR2_PACKAGE_PERL
 menu "Perl libraries/modules"
+       source "package/perl-appconfig/Config.in"
        source "package/perl-convert-asn1/Config.in"
        source "package/perl-crypt-blowfish/Config.in"
        source "package/perl-crypt-cbc/Config.in"
diff --git a/package/perl-appconfig/Config.in b/package/perl-appconfig/Config.in
new file mode 100644 (file)
index 0000000..0c40abb
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_PERL_APPCONFIG
+       bool "perl-appconfig"
+       help
+         AppConfig is a bundle of Perl5 modules for reading
+         configuration files and parsing command line arguments.
+
+         https://metacpan.org/release/AppConfig
diff --git a/package/perl-appconfig/perl-appconfig.hash b/package/perl-appconfig/perl-appconfig.hash
new file mode 100644 (file)
index 0000000..151a2e9
--- /dev/null
@@ -0,0 +1,6 @@
+# retrieved by scancpan from http://cpan.metacpan.org/
+md5    7747d9241561ed5567d5e134b8648707 AppConfig-1.71.tar.gz
+sha256 1177027025ecb09ee64d9f9f255615c04db5e14f7536c344af632032eb887b0f AppConfig-1.71.tar.gz
+
+# computed by scancpan
+sha256 0b22dd532e4123a511d14989c4169ed56b7316cf844c29c7897a1638a4616868 LICENSE
diff --git a/package/perl-appconfig/perl-appconfig.mk b/package/perl-appconfig/perl-appconfig.mk
new file mode 100644 (file)
index 0000000..7a553e3
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# perl-appconfig
+#
+################################################################################
+
+PERL_APPCONFIG_VERSION = 1.71
+PERL_APPCONFIG_SOURCE = AppConfig-$(PERL_APPCONFIG_VERSION).tar.gz
+PERL_APPCONFIG_SITE = $(BR2_CPAN_MIRROR)/authors/id/N/NE/NEILB
+PERL_APPCONFIG_LICENSE = Artistic or GPL-1.0+
+PERL_APPCONFIG_LICENSE_FILES = LICENSE
+
+$(eval $(perl-package))