projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
16012f5
)
package/freeswitch: add optional support for postgresql
author
Bernd Kuhls
<bernd.kuhls@t-online.de>
Fri, 4 May 2018 18:26:34 +0000
(20:26 +0200)
committer
Peter Korsgaard
<peter@korsgaard.com>
Sun, 6 May 2018 07:08:55 +0000
(09:08 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/freeswitch/freeswitch.mk
patch
|
blob
|
history
diff --git
a/package/freeswitch/freeswitch.mk
b/package/freeswitch/freeswitch.mk
index 98f2f483566b669913a08654b76bd7552f5f12ae..4d490b07304039cb0b0a7c7b08085edc1bbfdd1d 100644
(file)
--- a/
package/freeswitch/freeswitch.mk
+++ b/
package/freeswitch/freeswitch.mk
@@
-275,6
+275,17
@@
FREESWITCH_DEPENDENCIES += opencv
FREESWITCH_ENABLED_MODULES += applications/mod_cv
endif
+ifeq ($(BR2_PACKAGE_POSTGRESQL),y)
+FREESWITCH_CONF_ENV += \
+ ac_cv_path_PG_CONFIG=$(STAGING_DIR)/usr/bin/pg_config
+FREESWITCH_CONF_OPTS += \
+ --enable-core-pgsql-pkgconfig \
+ --enable-core-pgsql-support
+FREESWITCH_DEPENDENCIES += postgresql
+else
+FREESWITCH_CONF_OPTS += --disable-core-pgsql-support
+endif
+
ifeq ($(BR2_PACKAGE_UNIXODBC),y)
FREESWITCH_DEPENDENCIES += unixodbc
FREESWITCH_CONF_OPTS += \