webkitgtk24: fix building with rpi egl/gles
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 9 Feb 2016 13:17:57 +0000 (10:17 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 25 Feb 2016 21:41:40 +0000 (22:41 +0100)
Some egl/gles binary-only implementations need some extra help in the
form of additional include directories, like rpi-userland. Fixes:

http://autobuild.buildroot.net/results/083/083ce94b1ac61a60aa16906336612af59e32b18b/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/webkitgtk24/webkitgtk24.mk

index 712120c28bf5cb4f5d25da4b909ac631d5dbc2a3..0dc47748d0a9c97628ace7bbd99a778236dfce48 100644 (file)
@@ -13,8 +13,8 @@ WEBKITGTK24_LICENSE_FILES = \
        Source/WebCore/LICENSE-APPLE \
        Source/WebCore/LICENSE-LGPL-2
 WEBKITGTK24_DEPENDENCIES = host-ruby host-flex host-bison host-gperf \
-       enchant harfbuzz icu jpeg libcurl libgtk2 libsecret libsoup \
-       libxml2 libxslt sqlite webp
+       host-pkgconf enchant harfbuzz icu jpeg libcurl libgtk2 \
+       libsecret libsoup libxml2 libxslt sqlite webp
 
 WEBKITGTK24_DEPENDENCIES += \
        $(if $(BR_PACKAGE_XLIB_LIBXCOMPOSITE),xlib_libXcomposite) \
@@ -69,6 +69,10 @@ WEBKITGTK24_CONF_OPTS += \
        --enable-webgl \
        --disable-glx
 WEBKITGTK24_DEPENDENCIES += libegl libgles
+# Some EGL/GLES implementations needs extra help (eg. rpi-userland)
+WEBKITGTK24_CONF_ENV += CPPFLAGS="$(TARGET_CPPFLAGS) \
+       `$(PKG_CONFIG_HOST_BINARY) --cflags egl` \
+       `$(PKG_CONFIG_HOST_BINARY) --clfags glesv2`"
 # No GL
 else
 WEBKITGTK24_CONF_OPTS += \