package/mpv: link with libatomic if needed
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 15 Aug 2020 21:57:30 +0000 (23:57 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 16 Aug 2020 09:27:13 +0000 (11:27 +0200)
Fixes:
 - http://autobuild.buildroot.org/results/12f4580429427b6b546184366f74da16f83d692c

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/mpv/mpv.mk

index 8619de5a8e4d1f89f71b6ac02ac0dabb27ef5417..6801a0468f0219a8331b45d1eb45c62a3c8510d7 100644 (file)
@@ -235,4 +235,8 @@ else
 MPV_CONF_OPTS += --disable-x11
 endif
 
+ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
+MPV_CONF_ENV += LDFLAGS="$(TARGET_LDFLAGS) -latomic"
+endif
+
 $(eval $(waf-package))