jasper: Disable debugging when building for xtensa
authorMax Filippov <jcmvbkbc@gmail.com>
Tue, 19 May 2015 18:29:00 +0000 (21:29 +0300)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 19 May 2015 19:36:18 +0000 (21:36 +0200)
xtensa gcc is not able to generate correct code when compiling with -O0
enabled by --enable-debug. Instead of disabling package build it with
--disable-debug.

Fixes:
  http://autobuild.buildroot.net/results/5d17055027055ffd33fcd28b208130afb26343c9/

Signed-off-by: Max Filippov <jcmvbkbc@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/jasper/jasper.mk

index b2da07d76315deabc54667b808ff65a1682bda37..db86ae88e12694f535d5a98e182964b29ca2819f 100644 (file)
@@ -14,4 +14,10 @@ JASPER_LICENSE_FILES = LICENSE
 # needed to fix rpath issue (http://autobuild.buildroot.net/results/307/307cac65287420252a5bb64715d9a1edd90e72fa/)
 JASPER_AUTORECONF = YES
 
+# Xtensa gcc is unable to generate correct code with -O0 enabled by
+# --enable-debug. Allow package build but disable debug.
+ifeq ($(BR2_xtensa)$(BR2_ENABLE_DEBUG),yy)
+JASPER_CONF_OPTS += --disable-debug
+endif
+
 $(eval $(autotools-package))