python-see: new package
authorYegor Yefremov <yegorslists@googlemail.com>
Thu, 11 Jan 2018 09:25:19 +0000 (10:25 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 17 Jan 2018 22:37:56 +0000 (23:37 +0100)
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/python-see/Config.in [new file with mode: 0644]
package/python-see/python-see.hash [new file with mode: 0644]
package/python-see/python-see.mk [new file with mode: 0644]

index b133c93d5ee5f6a5464168d8215feaa5672520ec..85bb985e100b32c82bcdd04e40da522ed008f4b0 100644 (file)
@@ -897,6 +897,7 @@ menu "External python modules"
        source "package/python-schedule/Config.in"
        source "package/python-sdnotify/Config.in"
        source "package/python-secretstorage/Config.in"
+       source "package/python-see/Config.in"
        source "package/python-serial/Config.in"
        source "package/python-service-identity/Config.in"
        source "package/python-setproctitle/Config.in"
diff --git a/package/python-see/Config.in b/package/python-see/Config.in
new file mode 100644 (file)
index 0000000..f3049fd
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_PYTHON_SEE
+       bool "python-see"
+       help
+         dir for humans.
+
+         https://ljcooke.github.io/see/
diff --git a/package/python-see/python-see.hash b/package/python-see/python-see.hash
new file mode 100644 (file)
index 0000000..c48ee88
--- /dev/null
@@ -0,0 +1,4 @@
+# md5 from https://pypi.python.org/pypi/see/json, sha256 locally computed
+md5    cb3bf4d314f73a8f7a2fd3d2d99aab54  see-1.4.1.tar.gz
+sha256 14f8f8a88a909a7d7dea81f0016e3fdfabd3b5d335992e102a382e1a71672bd1  see-1.4.1.tar.gz
+sha256  dccbd040a7deacee7f05e5e46a8eba6e786ac319f0cb94c36f92d789585911a6  LICENSE
diff --git a/package/python-see/python-see.mk b/package/python-see/python-see.mk
new file mode 100644 (file)
index 0000000..982962b
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-see
+#
+################################################################################
+
+PYTHON_SEE_VERSION = 1.4.1
+PYTHON_SEE_SOURCE = see-$(PYTHON_SEE_VERSION).tar.gz
+PYTHON_SEE_SITE = https://pypi.python.org/packages/ff/fc/fcabb6a9bfe7c56798285839780cae67342256b823b97e94d862b0ba21d6
+PYTHON_SEE_SETUP_TYPE = setuptools
+PYTHON_SEE_LICENSE = BSD-3-Clause
+PYTHON_SEE_LICENSE_FILES = LICENSE
+
+$(eval $(python-package))