util-linux: fix install when locales are enabled
authorPeter Korsgaard <jacmet@sunsite.dk>
Fri, 12 Aug 2011 07:45:50 +0000 (09:45 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 12 Aug 2011 07:45:50 +0000 (09:45 +0200)
util-linux uses mkinstalldirs to install .po files when locales are
enabled, but the definition of MKINSTALLDIRS comes from a tweaked
nls.m4 (based on the one from gettext).

When we autoreconf the package, we end up using the system (staging)
version of nls.m4, so MKINSTALLDIRS doesn't get defined.

Fix it by passing a definition of MKINSTALLDIRS to make during the
install steps.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/util-linux/util-linux.mk

index dd6ee5c6970b93d8d2e10989a23cf02dfb530430..9d2f9be3b68b1b455fcaadc86fecdd6b3559a3eb 100644 (file)
@@ -68,3 +68,8 @@ UTIL_LINUX_CONF_OPT += \
        $(if $(BR2_PACKAGE_UTIL_LINUX_WRITE),--enable-write)
 
 $(eval $(call AUTOTARGETS,package,util-linux))
+
+# MKINSTALLDIRS comes from tweaked m4/nls.m4, but autoreconf uses staging
+# one, so it disappears
+UTIL_LINUX_INSTALL_STAGING_OPT += MKINSTALLDIRS=$(@D)/config/mkinstalldirs
+UTIL_LINUX_INSTALL_TARGET_OPT += MKINSTALLDIRS=$(@D)/config/mkinstalldirs