pulseaudio: bump version
authorPeter Korsgaard <peter@korsgaard.com>
Sun, 16 Mar 2014 20:06:40 +0000 (21:06 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 16 Mar 2014 20:06:40 +0000 (21:06 +0100)
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/pulseaudio/pulseaudio.mk

index 6a9e369ba37c16f57974a4becbd205677fc19df2..98e49bd81b5ff91c73e0917d5210d374ada0cb50 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-PULSEAUDIO_VERSION = 4.0
+PULSEAUDIO_VERSION = 5.0
 PULSEAUDIO_SOURCE = pulseaudio-$(PULSEAUDIO_VERSION).tar.xz
 PULSEAUDIO_SITE = http://freedesktop.org/software/pulseaudio/releases/
 PULSEAUDIO_INSTALL_STAGING = YES
@@ -41,6 +41,13 @@ else
 PULSEAUDIO_CONF_OPT += --disable-orc
 endif
 
+ifeq ($(BR2_PACKAGE_LIBCAP),y)
+PULSEAUDIO_DEPENDENCIES += libcap
+PULSEAUDIO_CONF_OPT += --with-caps
+else
+PULSEAUDIO_CONF_OPT += --without-caps
+endif
+
 ifneq ($(BR2_INSTALL_LIBSTDCPP),y)
 # The optional webrtc echo canceller is written in C++, causing auto* to want
 # to link module-echo-cancel.so with CXX even if webrtc ISN'T used.