lame: Disable debug symbols for Aarch64 and MIPS
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Thu, 30 Oct 2014 10:05:41 +0000 (10:05 +0000)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 30 Oct 2014 21:39:38 +0000 (22:39 +0100)
Building lame with debug symbols needs the following macros to be
defined: _FPU_MASK_IM, _FPU_MASK_ZM, _FPU_MASK_OM.
So, if BR2_ENABLE_DEBUG is selected, then we have to force lame to be
built without debug symbols for Aarch64 and MIPS because these
architectures don't have those macros defined.

Fixes:
http://autobuild.buildroot.net/results/721/721dff299b204b1d3ccc0846009eb17faa2d29eb/

Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/lame/lame.mk

index dcd155f47708e2e6f1092682d8b301d1d706a9a6..c179cef409aae41def02b1da4494cf56db52c4af 100644 (file)
@@ -14,6 +14,15 @@ LAME_CONF_OPTS = --enable-dynamic-frontends
 LAME_LICENSE = LGPLv2+
 LAME_LICENSE_FILES = COPYING
 
+# Building lame with debug symbols needs the following macros to be
+# defined: _FPU_MASK_IM, _FPU_MASK_ZM, _FPU_MASK_OM.
+# So, if BR2_ENABLE_DEBUG is selected, then we have force lame to be
+# built without debug symbols for Aarch64 and MIPS because these
+# architectures don't have those macros defined.
+ifeq ($(BR2_ENABLE_DEBUG)$(BR2_aarch64)$(BR2_mips)$(BR2_mipsel)$(BR2_mips64)$(BR2_mips64el),yy)
+LAME_CONF_OPTS += --disable-debug
+endif
+
 ifeq ($(BR2_PACKAGE_LIBSNDFILE),y)
 LAME_DEPENDENCIES += libsndfile
 LAME_CONF_OPTS += --with-fileio=sndfile