boost: change uses of BR2_JLEVEL to PARALLEL_JOBS
authorNathan Lynch <ntl@pobox.com>
Mon, 11 Jun 2012 16:09:38 +0000 (16:09 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 24 Jun 2012 09:09:46 +0000 (11:09 +0200)
Signed-off-by: Nathan Lynch <ntl@pobox.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/boost/boost.mk

index 366796440a08b9c910b1c59bd5a7512f69b6f2ce..abdf3a2c268e017ae2f1765e92acd0a25cae5bd7 100644 (file)
@@ -70,7 +70,7 @@ define BOOST_CONFIGURE_CMDS
 endef
 
 define BOOST_INSTALL_TARGET_CMDS
-       (cd $(@D) && ./b2 -j$(BR2_JLEVEL) -q -d+2 \
+       (cd $(@D) && ./b2 -j$(PARALLEL_JOBS) -q -d+2 \
        --user-config=$(@D)/user-config.jam \
        $(BOOST_OPT) \
        --prefix=$(TARGET_DIR)/usr \
@@ -78,7 +78,7 @@ define BOOST_INSTALL_TARGET_CMDS
 endef
 
 define BOOST_INSTALL_STAGING_CMDS
-       (cd $(@D) && ./bjam -j$(BR2_JLEVEL) -d+2 \
+       (cd $(@D) && ./bjam -j$(PARALLEL_JOBS) -d+2 \
        --user-config=$(@D)/user-config.jam \
        $(BOOST_OPT) \
        --prefix=$(STAGING_DIR)/usr \