trivial: use geturischeme helper function where possible
authorThomas De Schampheleire <patrickdepinguin+buildroot@gmail.com>
Fri, 19 Jul 2013 12:13:43 +0000 (14:13 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 21 Jul 2013 22:12:00 +0000 (00:12 +0200)
pkg-download.mk contains some helper functions to obtain subparts of URLs,
like the URI scheme. In pkg-generic.mk, there is still one opportunity to use
that helper function, instead of hardcoding it.

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/pkg-generic.mk

index 668f011b372504dc0f4b656de12e4a9048e3339b..b8eaa98bbb164eb97eccb3163825154d1b3a735a 100644 (file)
@@ -269,7 +269,7 @@ ifndef $(2)_SITE_METHOD
   $(2)_SITE_METHOD = $($(3)_SITE_METHOD)
  else
        # Try automatic detection using the scheme part of the URI
-       $(2)_SITE_METHOD = $(firstword $(subst ://, ,$(call qstrip,$($(2)_SITE))))
+       $(2)_SITE_METHOD = $(call geturischeme,$($(2)_SITE))
  endif
 endif