package/uclibc: use the generic help rules
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 4 Jun 2016 16:30:52 +0000 (18:30 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 7 Jun 2016 20:10:56 +0000 (22:10 +0200)
Note that the uclibc-menuconfig rule was guarded behind
BR2_TOOLCHAIN_BUILDROOT, which is wrong since we can build
glibc or musl toolchains too...

This is de facto fixed by moving the help text to the uClibc package.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Arnout Vandecappelle <arnout@mind.be>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
[Thomas: don't use the helper.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Makefile
package/uclibc/uclibc.mk

index bb3d5880887ce823fd2b066de36f60e47dff0e53..f007db2f299c899d1933d34be0da19dd68bb343e 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -941,9 +941,6 @@ help:
                @echo $(sep) \
                @echo '$($(p)_NAME):' $(sep) \
                $($(p)_HELP_CMDS)$(sep))
-ifeq ($(BR2_TOOLCHAIN_BUILDROOT),y)
-       @echo '  uclibc-menuconfig      - Run uClibc menuconfig'
-endif
 ifeq ($(BR2_TARGET_BAREBOX),y)
        @echo '  barebox-menuconfig     - Run barebox menuconfig'
        @echo '  barebox-savedefconfig  - Run barebox savedefconfig'
index e20e8a81785e20508a23f255736ef2b416582cf9..6bc5f41620ea215749a1776a367cd10f5bfd52ca 100644 (file)
@@ -11,6 +11,10 @@ UCLIBC_LICENSE = LGPLv2.1+
 UCLIBC_LICENSE_FILES = COPYING.LIB
 UCLIBC_INSTALL_STAGING = YES
 
+define UCLIBC_HELP_CMDS
+       @echo '  uclibc-menuconfig      - Run uClibc menuconfig'
+endef
+
 # uclibc is part of the toolchain so disable the toolchain dependency
 UCLIBC_ADD_TOOLCHAIN_DEPENDENCY = NO