linux: remove EABI conditional
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 13 Jul 2013 22:27:30 +0000 (00:27 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 14 Jul 2013 20:16:40 +0000 (22:16 +0200)
We're only EABI now, so we want to always build an EABI kernel
when we're building for ARM.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
linux/linux.mk

index dfc948ca515ba1cf843bcbef582e87580cdbdaa7..2ab437dd3f183395fbbcff1b05038784b32b455d 100644 (file)
@@ -170,9 +170,8 @@ define LINUX_CONFIGURE_CMDS
        cp $(KERNEL_SOURCE_CONFIG) $(KERNEL_ARCH_PATH)/configs/buildroot_defconfig
        $(TARGET_MAKE_ENV) $(MAKE1) $(LINUX_MAKE_FLAGS) -C $(@D) buildroot_defconfig
        rm $(KERNEL_ARCH_PATH)/configs/buildroot_defconfig
-       $(if $(BR2_ARM_EABI),
-               $(call KCONFIG_ENABLE_OPT,CONFIG_AEABI,$(@D)/.config),
-               $(call KCONFIG_DISABLE_OPT,CONFIG_AEABI,$(@D)/.config))
+       $(if $(BR2_arm)$(BR2_armeb),
+               $(call KCONFIG_ENABLE_OPT,CONFIG_AEABI,$(@D)/.config))
        # As the kernel gets compiled before root filesystems are
        # built, we create a fake cpio file. It'll be
        # replaced later by the real cpio archive, and the kernel will be