package/mplayer: add optional ncurses support
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 29 Mar 2015 17:11:19 +0000 (19:11 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 7 Apr 2015 20:51:45 +0000 (22:51 +0200)
[Thomas: don't pass --enable-termcap, and rely on autodetection
instead of forcing -lncurses.]

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mplayer/mplayer.mk

index 70a8842ea2272b7a4406ab7e5c3db4038ff8a445..06cddf60febc36bffb2a353f6c94c976e363b802 100644 (file)
@@ -45,6 +45,15 @@ else
 MPLAYER_CONF_OPTS += --disable-freetype
 endif
 
+# We intentionally don't pass --enable-termcap, in order to let the
+# autodetection find with which library to link with. Otherwise, we
+# would have to pass it manually.
+ifeq ($(BR2_PACKAGE_NCURSES),y)
+MPLAYER_DEPENDENCIES += ncurses
+else
+MPLAYER_CONF_OPTS += --disable-termcap
+endif
+
 ifeq ($(BR2_PACKAGE_LIBDVDREAD),y)
 MPLAYER_CONF_OPTS +=  \
        --enable-dvdread \