package/bird: make RIP optional
authorAdrien Gallouët <adrien@gallouet.fr>
Sat, 28 Sep 2019 07:36:02 +0000 (07:36 +0000)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 28 Sep 2019 21:34:26 +0000 (23:34 +0200)
In commit 529fef57f6f46201ba16349b49c0a65ceccc4c25 ("package/bird: add
optional protocols") we added options to conditionally enable
different protocol support. However, disabling the RIP support was not
working, so it remained forcefully enabled, and there was no
BR2_PACKAGE_BIRD_RIP option.

However, since the bump to 2.0.6 in commit
b9f43ade0fbce38b803214c167df52ca7fd3ee03, this issue has been fixed,
so we can introduce the BR2_PACKAGE_BIRD_RIP option, and make it
really optional.

Signed-off-by: Adrien Gallouët <adrien@gallouet.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/bird/Config.in
package/bird/bird.mk

index 22c39f8488bbd61b2a8a9a3f6a1eab137c2942b4..c2951c74c3246e57e8fe3f128ed56dcf541f95b3 100644 (file)
@@ -67,6 +67,11 @@ config BR2_PACKAGE_BIRD_RADV
        help
          Enable RAdv protocol.
 
+config BR2_PACKAGE_BIRD_RIP
+       bool "rip"
+       help
+         Enable RIP protocol.
+
 config BR2_PACKAGE_BIRD_STATIC
        bool "static"
        help
index 267968afb1fa878eb31fb1035dbc8c1eb4866383..46c868ac30fde8115ee7d0510c76110bc6ca6b94 100644 (file)
@@ -17,9 +17,7 @@ else
 BIRD_CONF_OPTS += --disable-client
 endif
 
-# BUG: RIP is mandatory for now
 BIRD_PROTOCOLS = \
-       rip \
        $(if $(BR2_PACKAGE_BIRD_BFD),bfd) \
        $(if $(BR2_PACKAGE_BIRD_BABEL),babel) \
        $(if $(BR2_PACKAGE_BIRD_BGP),bgp) \