libtirpc: fix build failure after non-IPv6 disabled
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 23 Apr 2015 04:44:18 +0000 (01:44 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 23 Apr 2015 07:44:08 +0000 (09:44 +0200)
Adjust patch 0005 to account for the removed optional IPv6 support
patch, since otherwise it won't apply. Fixes:
http://autobuild.buildroot.net/results/0ad/0ad8c9e331190f72280c3a1e3cd8d42728f818de/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libtirpc/0005-Automatically-generate-XDR-header-files-from-.x-sour.patch

index 3c1c82d0c779868f5b77f18e825575e90a381acb..023abd1114d6703e37910322a238425382b7a782 100644 (file)
@@ -4,6 +4,7 @@ Date: Sat, 10 Nov 2012 17:29:53 +0100
 Subject: [PATCH] Automatically generate XDR header files from .x sources using
  rpcgen
 
+[Gustavo: update after dropping non-IPv6 support]
 Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
 ---
  Makefile.am           |  22 +-
@@ -75,7 +76,7 @@ index f086255..a9db71b 100644
 @@ -8,7 +8,7 @@
  noinst_HEADERS = rpc_com.h
  
- AM_CPPFLAGS = -I$(top_srcdir)/tirpc -DPORTMAP \
+ AM_CPPFLAGS = -I$(top_srcdir)/tirpc -DPORTMAP -DINET6 \
 -              -D_GNU_SOURCE -Wall -pipe  
 +              -D_GNU_SOURCE -Wall -pipe -I$(top_builddir)/tirpc