libmicrohttpd: fix thread detection on ARC and Blackfin
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 3 Jul 2016 23:09:43 +0000 (01:09 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 5 Jul 2016 08:17:16 +0000 (10:17 +0200)
Due to compiler deficiences, gcc on ARC and Blackfin doesn't define
_REENTRANT, which the latest version of the ax_pthread.m4
autoconf-archive macros looks at to determine whether thread support is
available or not.

Fixing the compilers is definitely the right thing to do, but it's not
doable for pre-built external toolchains like the Blackfin one, so for
now, we simply define _REENTRANT manually on ARC and Blackfin. If more
packages are affected by this problem, a more general solution will have
to be found.

Fixes
http://autobuild.buildroot.net/results/593/593b5050473a83a9ddcada9de39f8f14ab38d554/
http://autobuild.buildroot.net/results/ff0/ff058a378b91740b5b399f32a6b375fbc3c8df06/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libmicrohttpd/libmicrohttpd.mk

index c53676f5207d6cc05e4af362a95ce590dacbc4bf..2266d3ceaad3c7c88fabd569463653f679a751ec 100644 (file)
@@ -9,7 +9,17 @@ LIBMICROHTTPD_SITE = $(BR2_GNU_MIRROR)/libmicrohttpd
 LIBMICROHTTPD_LICENSE_FILES = COPYING
 LIBMICROHTTPD_INSTALL_STAGING = YES
 LIBMICROHTTPD_CONF_OPTS = --disable-curl --disable-examples
-LIBMICROHTTPD_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -std=c99"
+LIBMICROHTTPD_CFLAGS = $(TARGET_CFLAGS) -std=c99
+
+# gcc on arc and bfin doesn't define _REENTRANT when -pthread is
+# passed while it should. Compensate this defiency here otherwise
+# libmicrohttpd configure script doesn't find that thread support is
+# enabled.
+ifeq ($(BR2_arc)$(BR2_bfin),y)
+LIBMICROHTTPD_CFLAGS += -D_REENTRANT
+endif
+
+LIBMICROHTTPD_CONF_ENV += CFLAGS="$(LIBMICROHTTPD_CFLAGS)"
 
 ifeq ($(BR2_PACKAGE_LIBMICROHTTPD_SSL),y)
 LIBMICROHTTPD_LICENSE = LGPLv2.1+