Add package for open2300
authorAlexandre Belloni <alexandre.belloni@piout.net>
Thu, 12 Jan 2012 14:03:02 +0000 (15:03 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 16 Jan 2012 15:45:21 +0000 (16:45 +0100)
Open2300 is a package of software tools that reads (and writes) data
from a Lacrosse WS2300/WS2305/WS2310/WS2315 Weather Station.

This package will install all the binaries on the target.

Signed-off-by: Alexandre Belloni <alexandre.belloni@piout.net>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/open2300/Config.in [new file with mode: 0644]
package/open2300/open2300.mk [new file with mode: 0644]

index 67b80948ec3c66a7cc3406b622530cd0f421cb4c..2e91427d0a236b8736e34ad0c9eaa6f61b00049d 100644 (file)
@@ -195,6 +195,7 @@ source "package/memtester/Config.in"
 source "package/mtd/Config.in"
 source "package/ntfs-3g/Config.in"
 source "package/ntfsprogs/Config.in"
+source "package/open2300/Config.in"
 source "package/openocd/Config.in"
 source "package/pciutils/Config.in"
 source "package/picocom/Config.in"
diff --git a/package/open2300/Config.in b/package/open2300/Config.in
new file mode 100644 (file)
index 0000000..df0a969
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_OPEN2300
+       bool "open2300"
+       help
+         open2300 reads (and writes) data from a Lacrosse
+         WS2300/WS2305/WS2310/WS2315 Weather Station
+
+         http://www.lavrsen.dk/foswiki/bin/view/Open2300/WebHome
diff --git a/package/open2300/open2300.mk b/package/open2300/open2300.mk
new file mode 100644 (file)
index 0000000..450b990
--- /dev/null
@@ -0,0 +1,29 @@
+############################################################
+#
+# Open2300
+#
+############################################################
+
+OPEN2300_SITE        = http://www.lavrsen.dk/svn/open2300/trunk/
+OPEN2300_SITE_METHOD = svn
+OPEN2300_VERSION     = 12
+
+OPEN2300_BINS = open2300 dump2300 log2300 fetch2300 wu2300 cw2300 history2300 \
+               histlog2300 bin2300 xml2300 light2300 interval2300 minmax2300
+
+ifeq ($(BR2_PACKAGE_MYSQL),y)
+       OPEN2300_DEPENDENCIES += mysql_client
+       OPEN2300_BINS         += mysql2300 mysqlhistlog2300
+endif
+
+define OPEN2300_BUILD_CMDS
+       $(MAKE) CC=$(TARGET_CC) LD=$(TARGET_LD) -C $(@D) $(OPEN2300_BINS)
+endef
+
+define OPEN2300_INSTALL_TARGET_CMDS
+       for prog in $(OPEN2300_BINS); do \
+               $(INSTALL) -D -m 0755 $(@D)/$$prog $(TARGET_DIR)/usr/bin/$$prog ; \
+       done
+endef
+
+$(eval $(call GENTARGETS))