package/libmediaart: remove qt4 support
authorPeter Korsgaard <peter@korsgaard.com>
Wed, 6 Feb 2019 14:10:53 +0000 (15:10 +0100)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Wed, 6 Feb 2019 14:41:30 +0000 (15:41 +0100)
Qt4 support is about to be dropped, so remove the support from libmediaart
as well.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/libmediaart/Config.in
package/libmediaart/libmediaart.mk

index e07367739598e51c61de78c2a777de7909a71266..c11d6f49d9cb232ec9b36cf215810e7585ec457f 100644 (file)
@@ -32,12 +32,11 @@ config BR2_PACKAGE_LIBMEDIAART_BACKEND_GDK_PIXBUF
 
 config BR2_PACKAGE_LIBMEDIAART_BACKEND_QT
        bool "Qt"
-       depends on BR2_PACKAGE_QT || BR2_PACKAGE_QT5
-       select BR2_PACKAGE_QT_GUI_MODULE if BR2_PACKAGE_QT
-       select BR2_PACKAGE_QT5BASE_GUI if BR2_PACKAGE_QT5
+       depends on BR2_PACKAGE_QT5
+       select BR2_PACKAGE_QT5BASE_GUI
 
-comment "Qt backend depends on Qt or Qt5"
-       depends on !BR2_PACKAGE_QT && !BR2_PACKAGE_QT5
+comment "Qt backend depends on Qt5"
+       depends on !BR2_PACKAGE_QT5
 
 endchoice
 
index f64210c26684924a61d65bc0490b6ab4b9edbb6e..a81542ac69d4ba986736cea042f05ec91fa6ce7e 100644 (file)
@@ -25,9 +25,7 @@ else ifeq ($(BR2_PACKAGE_LIBMEDIAART_BACKEND_QT),y)
 ifeq ($(BR2_PACKAGE_QT5_VERSION_LATEST),y)
 LIBMEDIAART_CONF_ENV += CXXFLAGS="$(TARGET_CXXFLAGS) -std=c++11"
 endif
-LIBMEDIAART_DEPENDENCIES += \
-       $(if $(BR2_PACKAGE_QT),qt) \
-       $(if $(BR2_PACKAGE_QT5),qt5base)
+LIBMEDIAART_DEPENDENCIES += qt5base
 LIBMEDIAART_CONF_OPTS += \
        --disable-gdkpixbuf \
        --enable-qt