package/util-linux: add file optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 31 Oct 2020 22:09:22 +0000 (23:09 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 31 Oct 2020 22:42:30 +0000 (23:42 +0100)
file is an optional dependency of more binary and is enabled by default
since version 2.36 and
https://github.com/karelzak/util-linux/commit/09070e1a658e70ec203150e4fa5f486b32771858

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/util-linux/util-linux-libs/util-linux-libs.mk
package/util-linux/util-linux.mk

index a0ec153bfb93ec480174d5cf0e48d9a7f392b4c8..3a3a655e62e820e93d4c0c25fa9f05823daf44c4 100644 (file)
@@ -83,4 +83,7 @@ UTIL_LINUX_LIBS_CONF_OPTS += --without-readline
 # No libs use audit
 UTIL_LINUX_LIBS_CONF_OPTS += --without-audit
 
+# No libs use libmagic
+UTIL_LINUX_LIBS_CONF_OPTS += --without-libmagic
+
 $(eval $(autotools-package))
index fae952eb7754dbe32f7ce181cd12f2c6af36279a..0b29ef4d6f549096278e004f5a5c14feea6186cd 100644 (file)
@@ -188,6 +188,7 @@ HOST_UTIL_LINUX_CONF_OPTS += \
        --enable-libblkid \
        --enable-libmount \
        --enable-libuuid \
+       --without-libmagic \
        --without-ncurses \
        --without-ncursesw \
        --without-tinfo
@@ -257,6 +258,13 @@ else
 UTIL_LINUX_CONF_OPTS += --without-audit
 endif
 
+ifeq ($(BR2_PACKAGE_FILE),y)
+UTIL_LINUX_CONF_OPTS += --with-libmagic
+UTIL_LINUX_DEPENDENCIES += file
+else
+UTIL_LINUX_CONF_OPTS += --without-libmagic
+endif
+
 # Install PAM configuration files
 ifeq ($(BR2_PACKAGE_UTIL_LINUX_SU)$(BR2_PACKAGE_LINUX_PAM),yy)
 define UTIL_LINUX_INSTALL_PAMFILES