barebox: add option to specify config fragments
authorFloris Bos <bos@je-eigen-domein.nl>
Tue, 28 Apr 2015 14:34:35 +0000 (16:34 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 21 May 2015 21:50:49 +0000 (23:50 +0200)
Signed-off-by: Floris Bos <bos@je-eigen-domein.nl>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
boot/barebox/Config.in
boot/barebox/barebox.mk

index a250f3b3440d76c79df4a2555e988c2a167ce63e..53d80139b4c22fda194f97752ab52ea2af4afae5 100644 (file)
@@ -91,6 +91,12 @@ config BR2_TARGET_BAREBOX_CUSTOM_CONFIG_FILE
        help
          Path to the barebox configuration file
 
+config BR2_TARGET_BAREBOX_CONFIG_FRAGMENT_FILES
+       string "Additional configuration fragment files"
+       help
+         A space-separated list of configuration fragment files,
+         that will be merged to the main Barebox configuration file.
+
 config BR2_TARGET_BAREBOX_BAREBOXENV
        bool "bareboxenv tool in target"
        help
index 294acbd4b5d245f9e645d010ff441157466693fa..7e530371c3d50879be732786c117cbee5d5f58d2 100644 (file)
@@ -64,6 +64,7 @@ BAREBOX_SOURCE_CONFIG = $(call qstrip,$(BR2_TARGET_BAREBOX_CUSTOM_CONFIG_FILE))
 endif
 
 BAREBOX_KCONFIG_FILE = $(BAREBOX_SOURCE_CONFIG)
+BAREBOX_KCONFIG_FRAGMENT_FILES = $(call qstrip,$(BR2_TARGET_BAREBOX_CONFIG_FRAGMENT_FILES))
 BAREBOX_KCONFIG_EDITORS = menuconfig xconfig gconfig nconfig
 BAREBOX_KCONFIG_OPTS = $(BAREBOX_MAKE_FLAGS)