Be really cereful to ensure udhcp.script is executable
authorEric Andersen <andersen@codepoet.org>
Mon, 3 Feb 2003 12:46:30 +0000 (12:46 -0000)
committerEric Andersen <andersen@codepoet.org>
Mon, 3 Feb 2003 12:46:30 +0000 (12:46 -0000)
make/busybox.mk

index 600266fd4a3d8b5f1cb2fd8612d95fea150faa65..bdbccafa0193041a68819d97a19d48478d7db7c0 100644 (file)
@@ -51,6 +51,8 @@ $(BUSYBOX_DIR)/busybox: $(BUSYBOX_DIR)/.configured
 
 $(TARGET_DIR)/bin/busybox: $(BUSYBOX_DIR)/busybox
        $(MAKE) CROSS="$(TARGET_CROSS)" PREFIX="$(TARGET_DIR)" -C $(BUSYBOX_DIR) install
+       # Just in case
+       -chmod a+x $(TARGET_DIR)/usr/share/udhcpc/default.script
 
 busybox: uclibc $(TARGET_DIR)/bin/busybox