package/mpd: fetch upstream patch to fix GCC 6 issue
authorJörg Krause <joerg.krause@embedded.rocks>
Thu, 9 Jun 2016 09:41:08 +0000 (11:41 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 9 Jun 2016 20:00:27 +0000 (22:00 +0200)
Fetch a patch from upstream to fix a build issue with GCC 6:

'''
In file included from /home/joerg/Development/git/buildroot/output/host/usr/arm-buildroot-linux-gnueabi/include/c++/6.1.0/bits/stl_algo.h:59:0,
                 from /home/joerg/Development/git/buildroot/output/host/usr/arm-buildroot-linux-gnueabi/include/c++/6.1.0/algorithm:62,
                 from ./src/queue/IdTable.hxx:25,
                 from ./src/queue/Queue.hxx:24,
                 from src/queue/Playlist.hxx:23,
                 from src/Partition.hxx:23,
                 from src/Instance.cxx:22:
/home/joerg/Development/git/buildroot/output/host/usr/arm-buildroot-linux-gnueabi/include/c++/6.1.0/cstdlib:75:25: fatal error: stdlib.h: No such file or directory
 #include_next <stdlib.h>
'''

Bug report: https://bugs.musicpd.org/view.php?id=4524
Fetch from: aa5d05eaa4d482aa8f8df954335d0aba151eeff9

Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mpd/mpd.hash
package/mpd/mpd.mk

index 2d35aaeb6294a57fb9472ff0af47f2b767c49367..f817a3a0d13e6abac9edbbb47fdfbccefe0a6266 100644 (file)
@@ -1,2 +1,3 @@
 # Locally calculated after checking pgp signature
 sha256  0cb9a223894b038ce966ce6d651d9b3ea3bdc7d7b9bec8d1e9e7e091cbc29b8b  mpd-0.19.15.tar.xz
+sha256  cb9a31889a3d01f373ad154dc4c0d13ca866d69bc02b3acd9f18727a756e78cb  aa5d05eaa4d482aa8f8df954335d0aba151eeff9.patch
index 6247d15d39b898922ad402fc3e9bed0084fc7080..9b054ffb6f42d234162a9fd0249b2ef9a04c8464 100644 (file)
@@ -13,6 +13,9 @@ MPD_LICENSE = GPLv2+
 MPD_LICENSE_FILES = COPYING
 MPD_AUTORECONF = YES
 
+# Fix GCC 6 issue (https://bugs.musicpd.org/view.php?id=4524)
+MPD_PATCH = https://github.com/MaxKellermann/MPD/commit/aa5d05eaa4d482aa8f8df954335d0aba151eeff9.patch
+
 # Some options need an explicit --disable or --enable
 
 # Zeroconf support depends on libdns_sd from avahi.