package/libvncserver: needs dynamic library
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 12 Jul 2019 21:29:18 +0000 (23:29 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 14 Jul 2019 11:35:26 +0000 (13:35 +0200)
Disable libvncserver for static builds and drop second patch following
upstream feedback on patch fixing openssl issue:
https://github.com/LibVNC/libvncserver/pull/319

This will also fix build failure when building statically with libgcrypt

Don't update x11vnc, the reverse dependency of libvncserver, because
BR2_PACKAGE_XORG7 already depends on !BR2_STATIC_LIBS

Fixes:
 - http://autobuild.buildroot.org/results/8d7b109d085e3931a874c4fb99f465789485565a

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libvncserver/0002-CMakeLists.txt-use-pkgconfig-to-find-openssl.patch [deleted file]
package/libvncserver/Config.in

diff --git a/package/libvncserver/0002-CMakeLists.txt-use-pkgconfig-to-find-openssl.patch b/package/libvncserver/0002-CMakeLists.txt-use-pkgconfig-to-find-openssl.patch
deleted file mode 100644 (file)
index c51b725..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
-From ab512233c88022fec67fabec1fb00a833c466c9e Mon Sep 17 00:00:00 2001
-From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-Date: Sun, 23 Jun 2019 22:54:57 +0200
-Subject: [PATCH] CMakeLists.txt: use pkgconfig to find openssl
-
-find_package(openssl) fails to find openssl dependencies such as -lz so
-use pkgconfig to fix static build
-
-Fixes:
- - http://autobuild.buildroot.org/results/c3f75480cb4b8b042cdf6a34cc5568ea13e51342
-
-Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-[Upstream status: https://github.com/LibVNC/libvncserver/pull/318]
----
- CMakeLists.txt | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index ad609ae..11103d8 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -125,7 +125,8 @@ endif(WITH_GNUTLS)
- if(WITH_OPENSSL)
--  find_package(OpenSSL)
-+  find_package(PkgConfig)
-+  pkg_check_modules(OPENSSL "openssl")
- endif(WITH_OPENSSL)
--- 
-2.14.1
-
index c8042905cefddeac50ed55fdef19fd272f1a8691..2d5bf8a18248ee287725abe951bb6d4e6e846c8b 100644 (file)
@@ -3,6 +3,7 @@ config BR2_PACKAGE_LIBVNCSERVER
        depends on BR2_USE_MMU # VNCommand.c uses fork()
        # binutils issue (bad expression)
        depends on !BR2_nios2
+       depends on !BR2_STATIC_LIBS
        select BR2_PACKAGE_LZO
        help
          libvncserver is a VNC server/client library.
@@ -22,3 +23,8 @@ config BR2_PACKAGE_LIBVNCSERVER_TIGHTPNG
          http://wiki.qemu.org/VNC_Tight_PNG
 
 endif
+
+comment "libvncserver needs a toolchain w/ dynamic library"
+       depends on BR2_USE_MMU
+       depends on !BR2_nios
+       depends on BR2_STATIC_LIBS