zlib: Replace negative logic in Makefile with positive
authorMichael Roth <mroth@nessie.de>
Tue, 29 Sep 2009 22:36:03 +0000 (00:36 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 30 Sep 2009 09:52:56 +0000 (11:52 +0200)
Positive logic is easier to read and understand than something
like 'if not option=yes then foo else bar'.

Signed-off-by: Michael Roth <mroth@nessie.de>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/zlib/zlib.mk

index 41d0632742ceae6079a8d2138d21d81af7122e97..a67a5e830f1365eac743ea5d073323c3179d0e28 100644 (file)
@@ -18,14 +18,14 @@ $(ZLIB_DIR)/.patched: $(DL_DIR)/$(ZLIB_SOURCE)
        $(CONFIG_UPDATE) $(@D)
        touch $@
 
-ifneq ($(BR2_PREFER_STATIC_LIB),y)
-ZLIB_PIC := -fPIC
-ZLIB_SHARED := --shared
-ZLIB_TARGET := $(TARGET_DIR)/usr/lib/libz.so
-else
+ifeq ($(BR2_PREFER_STATIC_LIB),y)
 ZLIB_PIC :=
 ZLIB_SHARED :=
 ZLIB_TARGET := $(STAGING_DIR)/usr/lib/libz.a
+else
+ZLIB_PIC := -fPIC
+ZLIB_SHARED := --shared
+ZLIB_TARGET := $(TARGET_DIR)/usr/lib/libz.so
 endif
 
 $(ZLIB_DIR)/.configured: $(ZLIB_DIR)/.patched