luarocks: new infrastructure
authorFrancois Perrad <fperrad@gmail.com>
Sat, 11 Jan 2014 15:42:07 +0000 (16:42 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 13 Jan 2014 22:17:18 +0000 (23:17 +0100)
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
[yann.morin.1998@free.fr: apply Thomas' comments]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Config.in
Makefile
package/Makefile.in
package/luarocks/luarocks.mk
package/pkg-luarocks.mk [new file with mode: 0644]

index 667c084664355efad6caddbd925f1fa90e8748e5..93d8fcede6be77f44cf6742e9e729ab2b7de44e2 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -217,6 +217,14 @@ config BR2_DEBIAN_MIRROR
 
 endif
 
+config BR2_LUAROCKS_MIRROR
+       string "LuaRocks mirror"
+       default "http://luarocks.org/repositories/rocks"
+       help
+         LuaRocks repository.
+
+         See http://luarocks.org
+
 endmenu
 
 config BR2_JLEVEL
index 9aa8536a0788dbeb357e3ececfdb2e9863ffa944..9adc0ec60968ec29f60e7852ab27a3f5994c707f 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -512,6 +512,7 @@ endif
 ifeq ($(BR2_PACKAGE_PYTHON_PYC_ONLY),y)
        find $(TARGET_DIR)/usr/lib/ -name '*.py' -print0 | xargs -0 rm -f
 endif
+       rm -rf $(TARGET_DIR)/usr/lib/luarocks
        $(STRIP_FIND_CMD) | xargs $(STRIPCMD) 2>/dev/null || true
        if test -d $(TARGET_DIR)/lib/modules; then \
                find $(TARGET_DIR)/lib/modules -type f -name '*.ko' | \
index f5d62899b411273461c20f5fb0026abe87f56e61..2e433fd60378301621ce7779ebe07fd00b78023e 100644 (file)
@@ -371,5 +371,6 @@ include package/pkg-utils.mk
 include package/pkg-download.mk
 include package/pkg-autotools.mk
 include package/pkg-cmake.mk
+include package/pkg-luarocks.mk
 include package/pkg-python.mk
 include package/pkg-generic.mk
index 149af0f2a8b615519f58306c9093ae100eb986a5..85b6866937737a62b3e3e71ed8e19697fbbdc0bc 100644 (file)
@@ -40,3 +40,6 @@ define HOST_LUAROCKS_INSTALL_CMDS
 endef
 
 $(eval $(host-generic-package))
+
+LUAROCKS_RUN = LUA_PATH="$(HOST_DIR)/usr/share/lua/5.1/?.lua" \
+       $(HOST_DIR)/usr/bin/lua $(HOST_DIR)/usr/bin/luarocks
diff --git a/package/pkg-luarocks.mk b/package/pkg-luarocks.mk
new file mode 100644 (file)
index 0000000..e82818a
--- /dev/null
@@ -0,0 +1,82 @@
+################################################################################
+# LuaRocks package infrastructure
+# see http://luarocks.org/
+#
+# This file implements an infrastructure that eases development of
+# package .mk files for LuaRocks packages.
+# LuaRocks supports various build.type : builtin, make, cmake.
+# This luarocks infrastructure supports only the builtin mode,
+# the make & cmake modes could be directly handled by generic & cmake infrastructure.
+#
+# See the Buildroot documentation for details on the usage of this
+# infrastructure
+#
+# In terms of implementation, this LuaRocks infrastructure requires
+# the .mk file to only specify metadata informations about the
+# package: name, version, etc.
+#
+################################################################################
+
+################################################################################
+# inner-luarocks-package -- defines how the configuration, compilation and
+# installation of a LuaRocks package should be done, implements a few hooks to
+# tune the build process and calls the generic package infrastructure to
+# generate the necessary make targets
+#
+#  argument 1 is the lowercase package name
+#  argument 2 is the uppercase package name, including an HOST_ prefix
+#             for host packages
+#  argument 3 is the uppercase package name, without the HOST_ prefix
+#             for host packages
+#  argument 4 is the package directory prefix
+#  argument 5 is the type (target or host)
+################################################################################
+
+define inner-luarocks-package
+
+$(2)_BUILD_OPT         ?=
+$(2)_SUBDIR            ?= $(1)-$(shell echo "$($(3)_VERSION)" | sed -e "s/-[0-9]$$//")
+$(2)_ROCKSPEC          ?= $(1)-$($(3)_VERSION).rockspec
+$(2)_SOURCE            ?= $(1)-$($(3)_VERSION).src.rock
+$(2)_SITE              ?= $(call qstrip,$(BR2_LUAROCKS_MIRROR))
+
+# Since we do not support host-luarocks-package, we know this is
+# a target package, and can just add the required dependencies
+$(2)_DEPENDENCIES      += host-luarocks luainterpreter
+
+# $(2)_DEPENDENCIES are handled for configure step (too late)
+# but host-luarocks is required to do the extract
+$(1)-extract: host-luarocks
+
+#
+# Extract step
+#
+ifndef $(2)_EXTRACT_CMDS
+define $(2)_EXTRACT_CMDS
+       cd $$($(2)_DIR)/.. && \
+        $$(LUAROCKS_RUN) unpack --force $(DL_DIR)/$$($(2)_SOURCE)
+endef
+endif
+
+#
+# Build/install step.
+#
+ifndef $(2)_INSTALL_TARGET_CMDS
+define $(2)_INSTALL_TARGET_CMDS
+       cd $$($(2)_SRCDIR) && \
+        $$(LUAROCKS_RUN) make --deps-mode=none --keep $$($(2)_ROCKSPEC) $$($(2)_BUILD_OPT)
+endef
+endif
+
+# Call the generic package infrastructure to generate the necessary
+# make targets
+$(call inner-generic-package,$(1),$(2),$(3),$(4),$(5))
+
+endef
+
+################################################################################
+# luarocks-package -- the target generator macro for LuaRocks packages
+################################################################################
+
+luarocks-package = $(call inner-luarocks-package,$(call pkgname),$(call UPPERCASE,$(call pkgname)),$(call UPPERCASE,$(call pkgname)),$(call pkgparentdir),target)
+# host-luarocks-package not supported