linux-pam: install default config
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 28 Nov 2013 17:22:26 +0000 (14:22 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 3 Dec 2013 08:04:23 +0000 (09:04 +0100)
Install default "other" configuration file that denies everything not
handled by other specific configurations.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/linux-pam/linux-pam.mk
package/linux-pam/other.pam [new file with mode: 0644]

index 7d2cbd3b545ae662d1518fd7ceea925985251fdf..6aa83e1c6f3c982a7b6bd59e8247251159e0bd86 100644 (file)
@@ -1,7 +1,7 @@
 ################################################################################
 #
 # linux-pam
-# 
+#
 ################################################################################
 
 LINUX_PAM_VERSION = 1.1.8
@@ -26,4 +26,12 @@ ifeq ($(BR2_NEEDS_GETTEXT_IF_LOCALE),y)
        LINUX_PAM_MAKE_OPT += LIBS=-lintl
 endif
 
+# Install default pam config (deny everything)
+define LINUX_PAM_INSTALL_CONFIG
+       $(INSTALL) -m 0644 -D package/linux-pam/other.pam \
+               $(TARGET_DIR)/etc/pam.d/other
+endef
+
+LINUX_PAM_POST_INSTALL_TARGET_HOOKS += LINUX_PAM_INSTALL_CONFIG
+
 $(eval $(autotools-package))
diff --git a/package/linux-pam/other.pam b/package/linux-pam/other.pam
new file mode 100644 (file)
index 0000000..a198aa2
--- /dev/null
@@ -0,0 +1,7 @@
+auth           required        pam_deny.so
+
+account                required        pam_deny.so
+
+password       required        pam_deny.so
+
+session                required        pam_deny.so