libcurl: security bump to 7.52.1
authorPeter Korsgaard <peter@korsgaard.com>
Fri, 23 Dec 2016 10:16:05 +0000 (11:16 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 23 Dec 2016 21:29:23 +0000 (22:29 +0100)
Fixes CVE-2016-9594 - Unitilized random

Libcurl's (new) internal function that returns a good 32bit random value was
implemented poorly and overwrote the pointer instead of writing the value
into the buffer the pointer pointed to.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libcurl/libcurl.hash
package/libcurl/libcurl.mk

index 2b68c6a7b492661021bc022cda5855caf7bdca8e..7a942f238b4f900e04fda5cc4a39b9470eba3171 100644 (file)
@@ -1,2 +1,2 @@
 # Locally calculated after checking pgp signature
-sha256 b9a2e18b4785eb75ad84598720e1559e1c53550ea011c0e00becdb94e2df5cc6  curl-7.52.0.tar.bz2
+sha256 d16185a767cb2c1ba3d5b9096ec54e5ec198b213f45864a38b3bda4bbf87389b  curl-7.52.1.tar.bz2
index b2a1b241dc70985cc15c9e537eaf183559ea66be..ea37309d82b01326fc8fe9af73f13d48b4004095 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-LIBCURL_VERSION = 7.52.0
+LIBCURL_VERSION = 7.52.1
 LIBCURL_SOURCE = curl-$(LIBCURL_VERSION).tar.bz2
 LIBCURL_SITE = https://curl.haxx.se/download
 LIBCURL_DEPENDENCIES = host-pkgconf \