btrfs-progs: drop dependency on e2fsprogs by not building btrfs-convert
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 21 Aug 2018 21:59:53 +0000 (23:59 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 22 Aug 2018 11:34:10 +0000 (13:34 +0200)
The btrfs-convert tool is used to convert an existing ext2 or reiserfs
filesystem into a btrfs filesystem. On the host, this is not really
useful, so let's disable building this tool, which allows to drop the
host-e2fsprogs dependency.

The host-util-linux dependency becomes necessary: it was previously
brought as a second-order dependency of host-e2fsprogs, but since we
no longer depend on host-e2fsprogs, we now need to explicitly depend
on host-util-linux.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/btrfs-progs/btrfs-progs.mk

index 3129ecc7149e04ba8d617524d26864b3a8e2f062..2f9f4127b65330586c67b91834545cb0aad72d7c 100644 (file)
@@ -21,8 +21,12 @@ BTRFS_PROGS_INSTALL_TARGET_OPTS = DESTDIR=$(TARGET_DIR) install-static
 BTRFS_PROGS_INSTALL_STAGING_OPTS = DESTDIR=$(STAGING_DIR) install-static
 endif
 
-HOST_BTRFS_PROGS_DEPENDENCIES = host-e2fsprogs host-lzo host-zlib
-HOST_BTRFS_PROGS_CONF_OPTS = --disable-backtrace --disable-zstd --disable-python
+HOST_BTRFS_PROGS_DEPENDENCIES = host-util-linux host-lzo host-zlib
+HOST_BTRFS_PROGS_CONF_OPTS = \
+       --disable-backtrace \
+       --disable-zstd \
+       --disable-python \
+       --disable-convert
 
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))