iproute2: disable xtables on static build
authorBaruch Siach <baruch@tkos.co.il>
Thu, 21 May 2015 06:07:45 +0000 (09:07 +0300)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 21 May 2015 21:22:52 +0000 (23:22 +0200)
iproute2 always builds m_xt.so as a shared library.

Fixes:
http://autobuild.buildroot.net/results/f42/f42bbbf5be4594a8806d0e571586ce2bf119582d/
http://autobuild.buildroot.net/results/3b3/3b37871bdf5766677fc20dca22c13177091d104f/

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/iproute2/iproute2.mk

index 9595165ec6a5ff0bae23491a47adf829e735f381..3315d67c467cf08eaa192be83648538b405de267 100644 (file)
@@ -18,7 +18,7 @@ IPROUTE2_DEPENDENCIES += busybox
 endif
 
 # If we've got iptables enable xtables support for tc
-ifeq ($(BR2_PACKAGE_IPTABLES),y)
+ifeq ($(BR2_PACKAGE_IPTABLES)x$(BR2_STATIC_LIBS),yx)
 IPROUTE2_DEPENDENCIES += iptables
 define IPROUTE2_WITH_IPTABLES
        # Makefile is busted so it never passes IPT_LIB_DIR properly
@@ -29,6 +29,7 @@ else
 define IPROUTE2_WITH_IPTABLES
        # em_ipset needs xtables, but configure misdetects it
        echo "TC_CONFIG_IPSET:=n" >>$(IPROUTE2_DIR)/Config
+       echo "TC_CONFIG_XT:=n" >>$(IPROUTE2_DIR)/Config
 endef
 endif