xapp_xedit: fix build with pkgconf 1.5.3
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 14 Dec 2018 15:26:19 +0000 (16:26 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 14 Dec 2018 20:23:13 +0000 (21:23 +0100)
Since the bump to 1.5.3, pkgconf prepends the sysroot to all absolute
paths found in the .pc file. This is correct when the paths refer to
something in STAGING_DIR (e.g. libdir, includedir), but not when it
refers to something used for the target.

xapp_xedit uses the appdefaultdir variable from xt.pc to decide where to
install things. Since DESTDIR is prepended to the install destination,
this will end up in the wrong location.

Until a better solution is found in pkgconf, pass the appdefaultdir to
use explicitly instead of relying on xt.pc.

Fixes:
 - http://autobuild.buildroot.org/results/1b46f950fc0d957d04c0a60a24176d701ff16bd9

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/x11r7/xapp_xedit/xapp_xedit.mk

index 0f42e2cb0d5cdca00bd090a9cfd8891ca6e68106..1cb99dc6f401ba91c2eb5e492b0283e84c0e4828 100644 (file)
@@ -11,6 +11,8 @@ XAPP_XEDIT_LICENSE = MIT
 XAPP_XEDIT_LICENSE_FILES = COPYING
 XAPP_XEDIT_DEPENDENCIES = xlib_libXaw
 
-XAPP_XEDIT_CONF_OPTS = --disable-selective-werror
+XAPP_XEDIT_CONF_OPTS = \
+       --disable-selective-werror \
+       --with-appdefaultdir=/usr/share/X11/app-defaults
 
 $(eval $(autotools-package))