Update coreutils build
authorEric Andersen <andersen@codepoet.org>
Wed, 15 Jan 2003 06:42:59 +0000 (06:42 -0000)
committerEric Andersen <andersen@codepoet.org>
Wed, 15 Jan 2003 06:42:59 +0000 (06:42 -0000)
make/coreutils.mk

index c02839b8e4c917d02827340efc135ca05c7ec708..aac13bdc3584d4a4f6e9e290b0f807ecb33b3e00 100644 (file)
@@ -22,9 +22,10 @@ $(COREUTILS_DIR)/.unpacked: $(DL_DIR)/$(COREUTILS_SOURCE)
        touch $(COREUTILS_DIR)/.unpacked
 
 $(COREUTILS_DIR)/.configured: $(COREUTILS_DIR)/.unpacked
-       (cd $(COREUTILS_DIR); autoconf; rm -f config.cache; CC=$(TARGET_CC1) \
-           CFLAGS=-D_POSIX_SOURCE ./configure --prefix=/usr --disable-nls \
-           --mandir=/junk --infodir=/junk \
+       (cd $(COREUTILS_DIR); rm -f config.cache; CC=$(TARGET_CC1) \
+            CFLAGS=-D_POSIX_SOURCE ./configure --prefix=/usr \
+            --target=$(ARCH)-linux --host=$(ARCH)-linux \
+            --disable-nls --mandir=/junk --infodir=/junk \
        );
        touch  $(COREUTILS_DIR)/.configured