erlang-goldrush: new package.
authorJohan Oudinet <johan.oudinet@gmail.com>
Mon, 12 Jan 2015 09:32:08 +0000 (10:32 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 3 Feb 2015 09:23:05 +0000 (10:23 +0100)
Signed-off-by: Johan Oudinet <johan.oudinet@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/erlang-goldrush/Config.in [new file with mode: 0644]
package/erlang-goldrush/erlang-goldrush.mk [new file with mode: 0644]

index 41544c72cfe16e6590ac62ae43974cb1c7dd725c..df09860764bae7e5a8243522f4fb93f232f17842 100644 (file)
@@ -397,6 +397,11 @@ endmenu
 menu "Interpreter languages and scripting"
        source "package/enscript/Config.in"
        source "package/erlang/Config.in"
+if BR2_PACKAGE_ERLANG
+menu "Erlang libraries/modules"
+       source "package/erlang-goldrush/Config.in"
+endmenu
+endif
        source "package/guile/Config.in"
        source "package/haserl/Config.in"
        source "package/jamvm/Config.in"
diff --git a/package/erlang-goldrush/Config.in b/package/erlang-goldrush/Config.in
new file mode 100644 (file)
index 0000000..2ee579a
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_ERLANG_GOLDRUSH
+       bool "erlang-goldrush"
+       help
+         Goldrush is a small Erlang app that provides fast event
+         stream processing.
+
+         https://github.com/DeadZen/goldrush
diff --git a/package/erlang-goldrush/erlang-goldrush.mk b/package/erlang-goldrush/erlang-goldrush.mk
new file mode 100644 (file)
index 0000000..b18a8ec
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# erlang-goldrush
+#
+################################################################################
+
+ERLANG_GOLDRUSH_VERSION = 0.1.6
+ERLANG_GOLDRUSH_SITE = $(call github,DeadZen,goldrush,$(ERLANG_GOLDRUSH_VERSION))
+ERLANG_GOLDRUSH_LICENSE = ISC
+ERLANG_GOLDRUSH_LICENSE_FILES = LICENSE
+ERLANG_GOLDRUSH_INSTALL_STAGING = YES
+
+$(eval $(rebar-package))
+$(eval $(host-rebar-package))