package/autossh: really fix the path to ssh
authorYann E. MORIN <yann.morin.1998@free.fr>
Fri, 27 Nov 2015 22:20:03 +0000 (23:20 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 28 Nov 2015 13:48:20 +0000 (14:48 +0100)
The ./configure script is not up-to-date with what is in configure.ac,
which prevents --with-ssh from working properly.

So, we autoreconfigure autossh, which fixes the issue.

Note however that this is not really an autotools package, since it only
uses autoconf and not automake. However, making it a generic pacakge is
not trivial, since autossh really wants config.h as generated by
./configure. Using the autotools infra in this case helps us easily
autoreconfiguring without to manual depend on all the autotools-relates
host packages.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/autossh/autossh.mk

index 8a9def3fbd97ccccba678a28ac4a8b8b6bb5fde1..d52b4e96667b5e86bf81da01f60e91be63ee5dc0 100644 (file)
@@ -10,6 +10,9 @@ AUTOSSH_SOURCE = autossh-$(AUTOSSH_VERSION).tgz
 AUTOSSH_LICENSE = Modified BSD
 AUTOSSH_LICENSE_FILES = autossh.c
 
+# Bundled ./configure is not up-to-date with what is in configure.ac
+AUTOSSH_AUTORECONF = YES
+
 AUTOSSH_CONF_OPTS = --with-ssh=/usr/bin/ssh
 
 define AUTOSSH_INSTALL_TARGET_CMDS