package/cukinia: new package
authorShyam Saini <mayhs11saini@gmail.com>
Tue, 5 May 2020 13:22:43 +0000 (09:22 -0400)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 6 Oct 2020 19:34:24 +0000 (21:34 +0200)
Cukinia is a test framework designed to help Linux-based embedded
systems developers run simple system-level validation tests on their
firmware.

It is designed to integrate well with embedded Linux systems
generation tools, and can be run manually (providing a quick
colourized summary to eye-catch regressions), or any of continuous
available integration framework, by generating Junit-XML or CSV test
reports.

Signed-off-by: Jérôme Oufella <jerome.oufella@savoirfairelinux.com>
Signed-off-by: Shyam Saini <shyam.saini@savoirfairelinux.com>
Tested-by: Angelo Compagnucci <angelo@amarulasolutions.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/cukinia/Config.in [new file with mode: 0644]
package/cukinia/cukinia.conf [new file with mode: 0644]
package/cukinia/cukinia.hash [new file with mode: 0644]
package/cukinia/cukinia.mk [new file with mode: 0644]

index f8655fa054e016bc5d89d2779cefdd25994f9fa4..407b2b2afc51b851534fd2f35bddcc9973c01a61 100644 (file)
@@ -2434,6 +2434,9 @@ F:        package/tunctl/
 F:     package/ubus/
 F:     package/wolfssl/
 
+N:     Shyam Saini <shyam.saini@savoirfairelinux.com>
+F:     package/cukinia/
+
 N:     Simon Dawson <spdawson@gmail.com>
 F:     boot/at91bootstrap3/
 F:     package/cppzmq/
index 51583d07d6ceea0aaf51358b395df8da3f68968c..22112b524e0b3a0f1fcfb73c1324a32bfd91027c 100644 (file)
@@ -155,6 +155,7 @@ menu "Development tools"
        source "package/check/Config.in"
        source "package/cmake/Config.in"
        source "package/cppunit/Config.in"
+       source "package/cukinia/Config.in"
        source "package/cunit/Config.in"
        source "package/cvs/Config.in"
        source "package/cxxtest/Config.in"
diff --git a/package/cukinia/Config.in b/package/cukinia/Config.in
new file mode 100644 (file)
index 0000000..37373e9
--- /dev/null
@@ -0,0 +1,15 @@
+config BR2_PACKAGE_CUKINIA
+       bool "cukinia"
+       select BR2_PACKAGE_GAWK if !BR2_PACKAGE_BUSYBOX
+       help
+         Cukinia is designed to help Linux-based embedded firmware
+         developers run system-level validation tests on their product.
+         It provides a simple POSIX shell overlay, and primitives to
+         make sure system integrations and features keep behaving the
+         way they should.
+
+         By default, cukinia reports colorized test results on stdout,
+         but can also report them as CSV and JUnit-XML for easy
+         integration with CI systems such as Jenkins.
+
+         https://github.com/savoirfairelinux/cukinia
diff --git a/package/cukinia/cukinia.conf b/package/cukinia/cukinia.conf
new file mode 100644 (file)
index 0000000..e5f304d
--- /dev/null
@@ -0,0 +1,4 @@
+# Note: Cukinia will produce colorized output if the TERM environment
+# variable matches vt220, xterm or linux.
+cukinia_log $(_colorize blue "############# Cukinia tests ##############")
+cukinia_user root
diff --git a/package/cukinia/cukinia.hash b/package/cukinia/cukinia.hash
new file mode 100644 (file)
index 0000000..e6ae602
--- /dev/null
@@ -0,0 +1,4 @@
+# locally computed
+sha256  b867ec63e448e7fa0a9276f6844a8b3a8f92d99e63e8518fe24e9debd32679b5  cukinia-0.5.1.tar.gz
+sha256  b40930bbcf80744c86c46a12bc9da056641d722716c378f5659b9e555ef833e1  LICENSE
+sha256  8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903  LICENSE.GPLv3
diff --git a/package/cukinia/cukinia.mk b/package/cukinia/cukinia.mk
new file mode 100644 (file)
index 0000000..84d4e60
--- /dev/null
@@ -0,0 +1,18 @@
+################################################################################
+#
+# cukinia
+#
+################################################################################
+
+CUKINIA_VERSION = 0.5.1
+CUKINIA_SITE = $(call github,savoirfairelinux,cukinia,v$(CUKINIA_VERSION))
+CUKINIA_LICENSE = Apache-2.0 or GPL-3.0
+CUKINIA_LICENSE_FILES = LICENSE LICENSE.GPLv3
+
+define CUKINIA_INSTALL_TARGET_CMDS
+       $(INSTALL) -D -m 0755 $(@D)/cukinia $(TARGET_DIR)/usr/bin/cukinia
+       $(INSTALL) -D -m 0644 $(CUKINIA_PKGDIR)/cukinia.conf \
+               $(TARGET_DIR)/etc/cukinia/cukinia.conf
+endef
+
+$(eval $(generic-package))