package/mesa3d: add optional support for libunwind
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 10 Jun 2017 11:53:47 +0000 (13:53 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 10 Jun 2017 21:01:50 +0000 (23:01 +0200)
Added by commit
https://cgit.freedesktop.org/mesa/mesa/commit/?h=17.1&id=70c272004f727457e852ba5f2498754b07a7d995

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mesa3d/mesa3d.mk

index f20d4398b3c3ad5f8ccfd0f2849d2e826e603881..2884063526eaff1abcda4996804271825001e97e 100644 (file)
@@ -189,6 +189,13 @@ else
 MESA3D_CONF_OPTS += --disable-xvmc
 endif
 
+ifeq ($(BR2_PACKAGE_LIBUNWIND),y)
+MESA3D_CONF_OPTS += --enable-libunwind
+MESA3D_DEPENDENCIES += libunwind
+else
+MESA3D_CONF_OPTS += --disable-libunwind
+endif
+
 ifeq ($(BR2_PACKAGE_LIBVDPAU),y)
 MESA3D_DEPENDENCIES += libvdpau
 MESA3D_CONF_OPTS += --enable-vdpau