python, python3: enable unicodedata for host-python, needed by setuptools
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 18 Feb 2014 20:40:05 +0000 (21:40 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 19 Feb 2014 07:53:12 +0000 (08:53 +0100)
As we are going to bump setuptools to a much newer version, the host
python needs to be built with support for unicodedata.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/python/python.mk
package/python3/python3.mk

index 0469820a68faec037d1408d44590fb19dfcc2a5a..3b0a4ddfd53618a59e4e563c92b1afed0417b29b 100644 (file)
@@ -25,7 +25,7 @@ HOST_PYTHON_CONF_OPT +=       \
        --disable-curses        \
        --disable-codecs-cjk    \
        --disable-nis           \
-       --disable-unicodedata   \
+       --enable-unicodedata    \
        --disable-dbm           \
        --disable-gdbm          \
        --disable-bsddb         \
index 1bf85004d0be4852d1ccbba36e36bf91afe90060..13f53f4f030032a868231f80b6b84f30cf767a24 100644 (file)
@@ -25,7 +25,7 @@ HOST_PYTHON3_CONF_OPT +=      \
        --disable-curses        \
        --disable-codecs-cjk    \
        --disable-nis           \
-       --disable-unicodedata   \
+       --enable-unicodedata    \
        --disable-test-modules  \
        --disable-idle3         \
        --disable-pyo-build