weston: disable v4l simple dmabuf for headers < 3.8
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 20 Apr 2016 16:54:43 +0000 (13:54 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 21 Apr 2016 21:26:00 +0000 (23:26 +0200)
It uses VIDIOC_EXPBUF which only came to light with kernel 3.8, so
disable it if headers are older. Fixes:
http://autobuild.buildroot.net/results/7fb/7fb9968b13f144c4576b28ecd01c82b74e4ed9d5/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/weston/weston.mk

index 9f7405c57a06bc6db1721f95012b9bc83f5e3505..63c43a3231888b463c5309b487242d15a7732d95 100644 (file)
@@ -28,6 +28,11 @@ WESTON_CONF_OPTS = \
 WESTON_MAKE_OPTS = \
        WAYLAND_PROTOCOLS_DATADIR=$(STAGING_DIR)/usr/share/wayland-protocols
 
+# Uses VIDIOC_EXPBUF, only available from 3.8+
+ifeq ($(BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_8),)
+WESTON_CONF_OPTS += --disable-simple-dmabuf-v4l-client
+endif
+
 ifeq ($(BR2_PACKAGE_DBUS),y)
 WESTON_CONF_OPTS += --enable-dbus
 WESTON_DEPENDENCIES += dbus