collectd: fix static linking
authorPeter Korsgaard <peter@korsgaard.com>
Sat, 15 Feb 2014 10:49:36 +0000 (11:49 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 15 Feb 2014 10:49:36 +0000 (11:49 +0100)
collectd-tg indirectly uses pthread, but forgets to link with -pthread.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/collectd/collectd.mk

index e1fc10434b979e82ce5ed9f2c1f7abbfc849ea8a..84e17cdf6858c5bbbf6cc24bf4774a0c7eda4fac 100644 (file)
@@ -6,7 +6,6 @@
 
 COLLECTD_VERSION = 5.4.1
 COLLECTD_SITE = http://collectd.org/files
-COLLECTD_MAKE_OPT = LDFLAGS="$(TARGET_LDFLAGS) -lm"
 COLLECTD_CONF_ENV = ac_cv_lib_yajl_yajl_alloc=yes
 COLLECTD_INSTALL_STAGING = YES
 COLLECTD_LICENSE = GPLv2 LGPLv2.1
@@ -22,6 +21,16 @@ COLLECTD_PLUGINS_DISABLE = amqp apple_sensors aquaero ascent dbi email \
                tokyotyrant uuid varnish vserver write_mongodb write_redis \
                xmms zfs_arc
 
+COLLECTD_LDFLAGS = $(TARGET_LDFLAGS) -lm
+
+ifeq ($(BR2_PREFER_STATIC_LIB),y)
+# collectd-tg indirectly needs pthread but doesn't link with -pthread,
+# causing static linker errors
+COLLECTD_LDFLAGS += -lpthread
+endif
+
+COLLECTD_CONF_ENV += LDFLAGS="$(COLLECTD_LDFLAGS)"
+
 COLLECTD_CONF_OPT += --with-nan-emulation --with-fp-layout=nothing \
        --localstatedir=/var --with-perl-bindings=no \
        $(foreach p, $(COLLECTD_PLUGINS_DISABLE), --disable-$(p)) \