infra/pkg-perl: add possibility to pass extra env at configure time
authorFrancois Perrad <fperrad@gmail.com>
Sun, 13 Jul 2014 13:03:21 +0000 (15:03 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 14 Jul 2014 11:06:59 +0000 (13:06 +0200)
Some perl packages may use environment variables as a hint to know how
to be configured.

That's for example the case for perl-net-ssleay that uses
OPENSSL_PREFIX, if it is set in the environment, as the prefix to
openssl.

Add a new variable that packages can set if they need extra environment
variables. Update the manual accordingly.

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Tested-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
[yann.morin.1998@free.fr: enhance the commit log]
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
docs/manual/adding-packages-perl.txt
package/pkg-perl.mk

index 4062646f452d26a955de2df21ba6d816098d1562..d1a1616916f3663dc9b7dd544e8fa5cfe7b06b42 100644 (file)
@@ -100,6 +100,10 @@ A few additional variables, specific to the Perl/CPAN infrastructure,
 can also be defined. Many of them are only useful in very specific
 cases, typical packages will therefore only use a few of them.
 
+* +PERL_FOO_CONF_ENV+/+HOST_PERL_FOO_CONF_ENV+, to specify additional
+  environment variables to pass to the +perl Makefile.PL+ or +perl Build.PL+.
+  By default, empty.
+
 * +PERL_FOO_CONF_OPT+/+HOST_PERL_FOO_CONF_OPT+, to specify additional
   configure options to pass to the +perl Makefile.PL+ or +perl Build.PL+.
   By default, empty.
index 5cfdc773709e14ab96f3516461cce3c3c16d60e6..8c4500161696de766451a580ae73886b716cee27 100644 (file)
@@ -49,6 +49,7 @@ ifeq ($(4),target)
 # Configure package for target
 define $(2)_CONFIGURE_CMDS
        cd $$($$(PKG)_SRCDIR) && if [ -f Build.PL ] ; then \
+               $$($(2)_CONF_ENV) \
                PERL_MM_USE_DEFAULT=1 \
                perl Build.PL \
                        --config ar="$$(TARGET_AR)" \
@@ -69,6 +70,7 @@ define $(2)_CONFIGURE_CMDS
                        --install_path libdoc=/usr/share/man/man3 \
                        $$($(2)_CONF_OPT); \
        else \
+               $$($(2)_CONF_ENV) \
                PERL_MM_USE_DEFAULT=1 \
                PERL_AUTOINSTALL=--skipdeps \
                perl Makefile.PL \
@@ -95,12 +97,14 @@ else
 # Configure package for host
 define $(2)_CONFIGURE_CMDS
        cd $$($$(PKG)_SRCDIR) && if [ -f Build.PL ] ; then \
+               $$($(2)_CONF_ENV) \
                PERL_MM_USE_DEFAULT=1 \
                perl Build.PL \
                        --install_base $$(HOST_DIR)/usr \
                        --installdirs vendor \
                        $$($(2)_CONF_OPT); \
        else \
+               $$($(2)_CONF_ENV) \
                PERL_MM_USE_DEFAULT=1 \
                PERL_AUTOINSTALL=--skipdeps \
                perl Makefile.PL \