package/xserver_xorg-server: don't install init script if nodm is enabled
authorPeter Korsgaard <peter@korsgaard.com>
Sat, 30 Jan 2021 10:18:33 +0000 (11:18 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 31 Jan 2021 22:15:10 +0000 (23:15 +0100)
Both S40xorg and S90nodm tries to run an Xserver on vt1, causing the nodm
one to fail.  If nodm is enabled, then that is likely what the user wants to
run, so skip installing S40xorg.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/x11r7/xserver_xorg-server/xserver_xorg-server.mk

index 8ac2d17b24626bea3fe79fd27128a6865aff424b..fa8ae13b8cfd6f97d9d21122ffa08777dfda02b3 100644 (file)
@@ -216,9 +216,12 @@ define XSERVER_XORG_SERVER_INSTALL_INIT_SYSTEMD
                $(TARGET_DIR)/usr/lib/systemd/system/xorg.service
 endef
 
+# init script conflicts with S90nodm
+ifneq ($(BR2_PACKAGE_NODM),y)
 define XSERVER_XORG_SERVER_INSTALL_INIT_SYSV
        $(INSTALL) -D -m 755 package/x11r7/xserver_xorg-server/S40xorg \
                $(TARGET_DIR)/etc/init.d/S40xorg
 endef
+endif
 
 $(eval $(autotools-package))