unionfs: new package
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 11 Jan 2012 14:11:58 +0000 (11:11 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 11 Jan 2012 14:36:27 +0000 (15:36 +0100)
Add the unionfs FUSE unification filesystem.

[Peter: whitespace/help text fix]
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/unionfs/Config.in [new file with mode: 0644]
package/unionfs/unionfs-make-mandir.patch [new file with mode: 0644]
package/unionfs/unionfs.mk [new file with mode: 0644]

index ac14d2c654aa1b8d235765fe5bce3f021986bbb6..1042d95fb8a7467a46166ec6725778a74d63724a 100644 (file)
@@ -212,6 +212,7 @@ source "package/sysstat/Config.in"
 source "package/ti-utils/Config.in"
 source "package/uboot-tools/Config.in"
 source "package/udev/Config.in"
+source "package/unionfs/Config.in"
 source "package/usb_modeswitch/Config.in"
 source "package/usbmount/Config.in"
 source "package/usbutils/Config.in"
diff --git a/package/unionfs/Config.in b/package/unionfs/Config.in
new file mode 100644 (file)
index 0000000..a974c8c
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_UNIONFS
+       bool "unionfs (FUSE)"
+       select BR2_PACKAGE_LIBFUSE
+       depends on BR2_LARGEFILE
+       help
+         A userspace unionfs implementation.
+
+         http://podgorny.cz/moin/UnionFsFuse
+
+comment "unionfs requires a toolchain with LARGEFILE support"
+       depends on !BR2_LARGEFILE
diff --git a/package/unionfs/unionfs-make-mandir.patch b/package/unionfs/unionfs-make-mandir.patch
new file mode 100644 (file)
index 0000000..bf3c241
--- /dev/null
@@ -0,0 +1,15 @@
+Make the man directory if it's missing before installing the man page.
+Already upstream see http://hg.podgorny.cz/unionfs-fuse/rev/6ca07ad1b855
+
+Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
+
+diff -Nura unionfs-fuse-0.24.orig/Makefile unionfs-fuse-0.24/Makefile
+--- unionfs-fuse-0.24.orig/Makefile    2010-05-20 08:04:08.000000000 -0300
++++ unionfs-fuse-0.24/Makefile 2012-01-11 08:08:02.382667776 -0300
+@@ -9,5 +9,6 @@
+ install: build
+       install -d $(DESTDIR)$(PREFIX)$(BINDIR)
++      install -d $(DESTDIR)$(PREFIX)/share/man/man8
+       install -m 0755 src/unionfs $(DESTDIR)$(PREFIX)$(BINDIR)
+       install -m 0644 man/unionfs-fuse.8 $(DESTDIR)$(PREFIX)/share/man/man8/
diff --git a/package/unionfs/unionfs.mk b/package/unionfs/unionfs.mk
new file mode 100644 (file)
index 0000000..b0bc93b
--- /dev/null
@@ -0,0 +1,20 @@
+#############################################################
+#
+# unionfs
+#
+#############################################################
+
+UNIONFS_VERSION = 0.24
+UNIONFS_SITE = http://podgorny.cz/unionfs-fuse/releases
+UNIONFS_SOURCE = unionfs-fuse-$(UNIONFS_VERSION).tar.bz2
+UNIONFS_DEPENDENCIES = libfuse
+
+define UNIONFS_BUILD_CMDS
+       $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)
+endef
+
+define UNIONFS_INSTALL_TARGET_CMDS
+       $(MAKE) -C $(@D) PREFIX=/usr DESTDIR=$(TARGET_DIR) install
+endef
+
+$(eval $(call GENTARGETS))