nfs-utils: install /etc/nfsmount.conf
authorJonathan Ben Avraham <yba@tkos.co.il>
Tue, 22 Dec 2015 17:12:17 +0000 (19:12 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 22 Dec 2015 18:12:47 +0000 (19:12 +0100)
Installs /etc/nfsmount.conf on the target, mainly to be able to configure the
the NFS version that mount.nfs uses by default. Without this ability you are
likely to encounter mount errors when automounting directories from NFS
version 3 servers.

Signed-off-by: Jonathan Ben Avraham <yba@tkos.co.il>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/nfs-utils/nfs-utils.mk

index 30f12fd44523a23a956bffceb1006915a9148515..6dd175cadbceb76aa3329e559c7e21f588a61d5d 100644 (file)
@@ -38,6 +38,8 @@ endif
 define NFS_UTILS_INSTALL_FIXUP
        rm -f $(NFS_UTILS_TARGETS_)
        touch $(TARGET_DIR)/etc/exports
+       $(INSTALL) -D -m 644 \
+               $(@D)/utils/mount/nfsmount.conf $(TARGET_DIR)/etc/nfsmount.conf
 endef
 NFS_UTILS_POST_INSTALL_TARGET_HOOKS += NFS_UTILS_INSTALL_FIXUP