qt5webengine: fix build issue with alsa
authorGaël PORTAY <gael.portay@savoirfairelinux.com>
Wed, 14 Feb 2018 02:37:14 +0000 (21:37 -0500)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 19 Feb 2018 22:45:38 +0000 (23:45 +0100)
Qt WebEngine auto-guesses if it compiles support for alsa. When the
alsa-lib config is enabled but the features mixer, rawmidi, hwdep and
seq are not also enabled, it leads to a build failure.

Lets the developer decide whether or not support for alsa in Qt
WebEngine by adding the new config BR2_PACKAGE_QT5WEBENGINE_ALSA that
selects the features it needs when it is set.

Fixes [1].

[1]: http://autobuild.buildroot.net/results/d81537a8f67bb0a3625057560b2f16daf4828f98/build-end.log

Signed-off-by: Gaël PORTAY <gael.portay@savoirfairelinux.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/qt5/qt5webengine/Config.in
package/qt5/qt5webengine/qt5webengine.mk

index d0c8d18210be0e9392649295c907b942d8579e52..7c99255061dad51eb7badae65c60d539089f4498 100644 (file)
@@ -81,4 +81,14 @@ config BR2_PACKAGE_QT5WEBENGINE_PROPRIETARY_CODECS
          which includes required proprietary audio and video codecs,
          such as H.264 and MPEG layer-3 (MP3).
 
+config BR2_PACKAGE_QT5WEBENGINE_ALSA
+       bool "alsa"
+       select BR2_PACKAGE_ALSA_LIB
+       select BR2_PACKAGE_ALSA_LIB_MIXER
+       select BR2_PACKAGE_ALSA_LIB_RAWMIDI
+       select BR2_PACKAGE_ALSA_LIB_HWDEP
+       select BR2_PACKAGE_ALSA_LIB_SEQ
+       help
+         Enable ALSA support.
+
 endif
index 365d7d5a171c2692b8f959109e4b0ea42464748d..4d423f8329b83ccc1af9c19925522f722d235431 100644 (file)
@@ -28,6 +28,12 @@ ifeq ($(BR2_PACKAGE_QT5WEBENGINE_PROPRIETARY_CODECS),y)
 QT5WEBENGINE_QMAKEFLAGS += WEBENGINE_CONFIG+=use_proprietary_codecs
 endif
 
+ifeq ($(BR2_PACKAGE_QT5WEBENGINE_ALSA),y)
+QT5WEBENGINE_DEPENDENCIES += alsa-lib
+else
+QT5WEBENGINE_QMAKEFLAGS += QT_CONFIG-=alsa
+endif
+
 # QtWebengine's build system uses python, but only supports python2. We work
 # around this by forcing python2 early in the PATH, via a python->python2
 # symlink.