package/strongswan: Install libraries to /usr/lib
authorSam Voss <sam.voss@rockwellcollins.com>
Tue, 12 Dec 2017 22:19:38 +0000 (16:19 -0600)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 13 Dec 2017 13:06:43 +0000 (14:06 +0100)
Install strongswan ipsec libraries into /usr/lib instead of
/usr/lib/ipsec to place them in preferred library common location.

Signed-off-by: Sam Voss <sam.voss@rockwellcollins.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/strongswan/strongswan.mk

index 30bbc6c85294f35c05c0f944a5676f92893b4433..65618af33b1226ad131d8273893095a1d853d64b 100644 (file)
@@ -37,7 +37,10 @@ STRONGSWAN_CONF_OPTS += \
        --enable-scepclient=$(if $(BR2_PACKAGE_STRONGSWAN_SCEP),yes,no) \
        --enable-scripts=$(if $(BR2_PACKAGE_STRONGSWAN_SCRIPTS),yes,no) \
        --enable-vici=$(if $(BR2_PACKAGE_STRONGSWAN_VICI),yes,no) \
-       --enable-swanctl=$(if $(BR2_PACKAGE_STRONGSWAN_VICI),yes,no)
+       --enable-swanctl=$(if $(BR2_PACKAGE_STRONGSWAN_VICI),yes,no) \
+       --with-ipseclibdir=/usr/lib \
+       --with-plugindir=/usr/lib/ipsec/plugins \
+       --with-imcvdir=/usr/lib/ipsec/imcvs
 
 ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
 STRONGSWAN_CONF_ENV += LIBS='-latomic'